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 INTRODUCTION 
Features 
Create and edit limit pattern, compensation table and marker files. 

Create limit pattern files from Log, Scan and Trace files. 

Open data files for further analysis.  

Upgrade PSAxx02 setup file(s) to PSAxx03 format. 

Live view of the PSA display. 

Intended Use 
List of compatible instruments: 

(Firmware updates may be required for compatibility)  

Spectrum Analysers 

Series Models 

2 PSA1302 & PSA2702  

3 PSA1303 & PSA2703 

5 PSA3605 & PSA6005 

Colour coding:  

Green = Larger view / selected area 

① Orange = Instruction to select  

① Blue = Optional instruction to select 

① Yellow = Description of item 

Symbols 
The following symbols are displayed throughout the manual: 

CAUTION  
Indicates a hazard that could damage the product that may result in loss of important 
data or invalidation of the warranty.  

 

NOTE 
Indicates a helpful tip.  
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 PSA LIVE VIEW 
Connect the PSA to the PC using a USB cable and the mini-B connector on the PSA. 

The Windows plug and play functions should automatically recognise the addition of new hardware 
attached to the USB interface and establish a virtual COM port within the PC. 

To view the PSA display on a PC, the PSA must be put into the View on PC mode. To enable View on 
PC, select : 

Setup/Functions > System/file Ops > System Utilities > Status/System > Screen > View on PC. 

Follow the on-screen prompts to establish a connection. 

NOTE 
The View on PC mode is only available when Option U01 or U02 is enabled on the PSA. 

 

Select Connection > PSA Live View to enable the connection between the PSA and Test Bridge PSA.  

A Pop- up will appear, on the COM Port dropdown box select the COM port which is connected to the 
PSA and select Connect. If the COM port does not appear in the list, click the Refresh button and try 
again. 

 
The connection process may take a few moments.  

Once connected, the PSA screen will appear in the graphics window. Now changes on the PSA screen 
will also be seen in the graphics window. Operation of the PSA will slow down a little due to the large 
volume of data now flowing to the PC. Screen images can be captured using any of the following: 
Right click> Export, File > Save or File > Export. 

To stop viewing on the PC, close the PSA Live View tab. 

NOTE 
If disconnected, the PSA will leave the ‘view on PC’ mode, when reconnected it will require re-
enabling. 
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 FILE TYPES 
Images 
Screen bitmaps (*.BMP) are stored in the IMAGES folder and are Windows bitmap images of the PSA 
screen. 

Imports 
The folder named IMPORTS is used for external .CSV files that are not created on the instrument or 
within Test Bridge PSA. 

Log Files 
Log files (*.LOG) are stored in the LOGS folder and contain multiple entries of sweep data. They can 
contain several types of data and are variable in size up to tens of megabytes. If View trace/ Limit 
Patterns/ Channel Markers are loaded at the time of saving, they will also be contained within the 
Log file. They will be visible if enabled during the logging process. 

There are four types of log file which may be created by the PSA: 
Full Trace 

This file type contains the complete trace data for each log file entry. 

Peak Level  

This file type contains two values for each log entry these being the level at the highest peak in the 
trace together with the corresponding frequency value.  
Centre Level 

This type of file contains a single value for each log entry which is the value representing the level at 
the centre frequency of the original trace on the PSA.  
Screen Image  

This log file type contains a bitmap image of the trace for each log file entry. 

Setups 
Setups are used to save the configuration of the PSA; Test Bridge PSA does not load setups. 

Use Tools>File Upgrade tool to upgrade PSAxx02 format files to PSAxx03 format. 

Tables 
Compensation Tables   

Compensation tables (*.CMP) are stored in the TABLES folder and are normalised files of amplitude 
compensation versus frequency created by Test Bridge PSA. 

Compensation tables are normalised files of amplitude versus frequency that are used to 
compensate for frequency related non-linearity in antennae or transducers.  

The files contain lists of up to 49 frequency/amplitude points. When a file is used by the instrument, 
linear interpolation is employed between the points. Every point on the trace is then changed by the 
amount calculated from the interpolated compensation table. Note that this could result in parts of 
the trace being outside of the graticule area.  
Limit Patterns  

Limit Patterns (*.CSV) are stored in the TABLES folder and contain absolute values of amplitude 
versus frequency created by Test Bridge PSA. 

Limit lines or patterns may be used as simple visual aids to determine whether a signal is within a 
specific level range, or they may be used in conjunction with the Limits Comparator to create an 
automatic action.  
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Limit Patterns can be displayed on the screen of the PSA, they can have multiple levels and can 
include vertical steps and angled lines. Patterns are contained within files that are lists of up to 49 
frequency/amplitude points. When a file is used by the instrument, linear interpolation is employed 
between the points. Up to two patterns can be displayed simultaneously in different colours (red and 
blue). 
Channel Markers  

Channel Markers ($*.CSV) are a special case of Limit Patterns that are also stored in the TABLES 
folder. They are created by Test Bridge PSA from a list of frequency values only. 

Channel Markers are a special case of a Limit Pattern which consists only of vertical lines at frequency 
points defined within the file. These can be displayed as an alternative to limit lines/patterns on the 
PSA. Up to two files can be displayed simultaneously in differing colours. Each file can contain up to 
49 frequency points.  

Traces  
Trace Files 

Traces (*.CSV) are stored in the TRACES folder and are lists of frequency/amplitude pairs 
representing the data from a single trace captured by the PSA. 

Trace files have a .CSV extension and do NOT start with a $ symbol.  

Scan Files (PSA Series 5 only) 

Scan Files ($*.CSV) are stored in the TRACES folder. Scan files always start with a $ symbol to 
distinguish them from Trace files. 
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 CREATING FILES TO USE ON THE PSA  
Test Bridge PSA allows custom Limit Pattern, Compensation Table and Channel Marker files to be 
created, these can be transferred onto a PSA for further use. See ‘Transferring Files’ for details on 
how to transfer files to the PSA.  

To create a new file, select the required file type from: File > New ①. 

Once a new file type is selected, a pop-up will appear with various settable options depending on the 
selection:  

 

Edit the values as required and click OK to create the file. 

Alternatively, choose Import from CSV file to import values from an external .CSV file from the 
IMPORT folder. See ‘File Locations’ for more details.  

Test Bridge PSA also provides a feature to allow an existing file (Log, Trace, Scan) to be used as the 
basis for a Limit Pattern. See ‘Creating a Limit Pattern file from a trace’. 

  

① 
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Editing Values 
Values can be edited on Limit Pattern, Compensation Table and Channel Marker files. 

To edit a frequency/ level value, double click on the required field ①, enter a new frequency/ level 
and press the Return key on the keyboard. If an invalid number is entered the box will show an error 
②.  

Alternatively, both values can be edited simultaneously from the graph window. Select a point on the 
graph ③, hold the Ctrl key then click and drag the required point to the new frequency/ level.  

To edit the level / frequency independently using the graph, select a point on the graph, hold Ctrl and 
Shift / Alt keys then click and drag the required point to the new level. 

The List will reorder once the editing is complete. 

NOTE 
The first and last frequency points can only be modified in the table. 
 

 
Insert a New Point 

To insert a point into the list, select either the frequency or the level value, right click in the list 
window ① and select Insert Before, or Insert After, as required.  

To insert a point into the graph, right click on the required point ③ and select either Insert Before, 
or Insert After, as required. 

Inserting a point before creates a new point with a value calculated using the average of the selected 
point and the previous one.   

Inserting a point after creates a new point with a value calculated using the average of the selected 
point and the next one.   
Copy/Paste 

To copy a set of values, select either the frequency, level value or point from the graphic window, 
right click ③ and select Copy. 

To paste a copied value, select either the frequency, level value or point from the graphic window 
right click ③ and select Paste. 
Delete 

To delete a point, select either the frequency, level value or point from the graphic window, right click 
③ and select Delete.  

Select point (Left Click)  

= Pan 
+ Ctrl =     (both values)  
+ Ctrl + Shift =  (level only)  
+ Ctrl + Alt =  (frequency)  

Select point (Right Click) + drag.  

① ② 

③ 
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 IMPORTING AND OPENING A FILE 
File Locations 
The files used by Test Bridge PSA are stored in a folder structure similar to that used by the PSA itself. 
By default, the top-level folder created at installation is called PSAman, this is located in the 
Documents folder. It holds several other folders containing the different types of files.  

Transferring Files  

Files need to be transferred from the PSA to a PC before using. This can be done either using a USB 
Flash drive or by direct USB connection and “Link to PC” (Setup/Functions > System/File Ops > 
File Ops > Link to PC).  

Transfer the files as detailed in the table: 

 

 

 

 

 

 

 

 

PSAman ‘Home’ Folder 

The ‘Home’ Folder is where Test Bridge PSA will locate all relevant files. The top-level folder, created 
at installation, is named PSAman.  

It is possible to create multiple ‘Home’ folders on any available disk drive and set Test Bridge PSA to 
use any one of them as the default. This allows multiple projects to be created and Test Bridge PSA 
will only use the files for the selected project.  

To point Test Bridge PSA to another folder simply use File > Set Home Folder, navigate to the 
required folder and click OK. Test Bridge PSA will then remember the new location until it is changed 
again. 

  

File Type  Extension Transfer files from folder: Transfer files to folder: 
Image .BMP PSA\IMAGES  PSAman\IMAGES  
Trace .CSV PSA\TRACES  PSAman\TRACES  
Scan $_ .CSV PSA\TRACES PSAman\TRACES  
Full Trace .LOG PSA\LOGS  PSAman\LOGS  
Peak Level  .LOG PSA\LOGS  PSAman\LOGS  
Centre Level .LOG PSA\LOGS  PSAman\LOGS  
Screen Image .LOG PSA\LOGS  PSAman\LOGS  
Compensation Table .CMP PSA\TABLES  PSAman\TABLES 
Limit Pattern .CSV PSA\TABLES  PSAman\TABLES 
Channel Markers $_.CSV PSA\TABLES  PSAman\TABLES 
External  
(not created on the PSA) 

.CSV - PSAman\IMPORTS 
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Open a File  
To open a file, select the required file type from: File > Open ①. 

This will show the contents of the appropriate folder for the selected file type.  
For more information on file types and locations, see ‘File Types’ or ‘File Locations’. 

Opening a file will create a new tab ② along the top of the window. To view the file, select the 
required tab. The tab layout will vary depending on the file type, each file type is described in the 
following section.  

 

Hover the mouse over a tab ② to see the full file name and location details ③. 

 

  

xxxxxxxxxx 

 

① 

② 

③ 
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 WINDOW / TAB LAYOUT 
Limit Patterns, Compensation Tables and Channel Markers  

Limit Pattern and Compensation Tables  

 Limit Pattern and Compensation Table files contain a list of frequency/level pairs, as a table ①, 
alongside a graph ②.  

The list of frequency/level pairs (minimum 2, maximum 49) define the absolute value of the limit 
pattern at the given frequency. The level of the limit pattern at frequencies not listed will be 
calculated by linear interpolation between the nearest frequency points above and below the 
required frequency. Level values may be in the range  -120dBm to +120dBm, frequency values may be 
in the range of 1 and 6000MHz. 

  

① 

② 

① 

② 

③ ④ 

③ ④ 
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Level Shift 

To apply a user defined shift to all points in the limit pattern, enter the shift value into the Level Shift 
parameter ③; the value may be positive or negative. Each time the Apply button ④ is clicked the 
Level Shift value will be applied to all points in the limit pattern. If the new level is outside of the 
allowed range or an invalid number, the Apply button will be disabled. Values between -100 and 
+100 are allowed. 

For details on editing the values and graph, see ‘Editing and graph controls’. 

Channel Markers 

Channel Marker files contain a single list of frequency points ① that represent the points at which 
display markers are required (minimum 1, maximum 49 points). The Channel Marker window 
contains no graphical display.   

  

① 
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Log, Scan and Trace Files 

Common Features 

File Details  

Log, Scan and Trace files, show the details of the file ① alongside a graph ②. The details of the file 
are always shown on the left of the screen.  
Tabs 

The graph contains tabs along the top ③, the tab contents will vary depending on which file type is 
selected, these are described further in the following sections. Each tab has a drop-down menu ④ 
and a visibility toggle button ⑤.  
Max / Min Stats 

The Minimum and Maximum levels of the selected log are shown as a point ⑥ (coloured dot) on the 
graph, details of these points are shown at the bottom of the graphical window ⑦ in the reference 
colour. 
Splitter Bar 

The thicker grey dividing line ⑧ indicates a ‘splitter bar’ and that the window size can be adjusted 
by clicking and dragging the bar into the required place. 
Memo 

A Memo area is provided ⑨ into which explanatory notes can be typed, a .MEMO file will be 
automatically saved in the assigned file location and recalled when the file is opened, the original file 
is not altered. This can also be viewed separately as a text file if required. 

  

① 

② 

③ 

⑤ ④ 
⑥ 

⑥ 

 
⑦ 

⑧ 

⑨ 
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Creating a Limit Pattern File from a Log, Scan or Trace File  

It is possible to create a Limit pattern file from a log file trace. This can be a useful starting point for 
limit patterns intended to show the acceptable boundaries for known trace shapes. 

To create a limit pattern, select the drop-down box ① on the required trace tab. 

Set the number of points to use when creating the limit pattern in the Points parameter box ②, the 
enveloped option will attempt to create a rectangular area about the highest peak in the trace data. 
Click ③ to select and create the pattern. A new List window will open containing the values 
calculated for the new pattern and the Graphic window will show the new pattern ④.  

The number of points will need to be at least twice the number of peaks in the trace data to get a 
meaningful result. The number cannot exceed 49.  

Creating a Trace File from a Log File  

It is possible to create a Trace file from a log file trace. 

To create the Trace file, select the drop-down box ① on the required trace tab and select Create 
Trace File ⑤. 

 
  

① ② 

③ 

④
 

⑤ 
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Log Files 

The Log Entries window shows the selected trace ① in the Log File Browser window ②.  

The Live Trace ③ is always shown and cannot be removed from the Graphic window. If the log file 
contains a View Trace, Reference Trace or Limit Lines, these may be shown in the Graphic window by 
either selecting the tab or using the drop-down list. Once shown, the ‘visible’ icon will appear in the 
tab. See ‘Common features’ for more details. 

If the log file contains a limit pattern for Limit 1 or Limit 2 these may be shown in the same way. 
Items not available will be greyed out.  

The displayed log entry is highlighted in the Log File Browser window ④. 

Multiple log entries can be viewed on the graph. To select more than one log entry to view, hold the 
ctrl key and select individual logs to be viewed ⑤. Alternatively, hold the Shift key and select a range 
of log entries to view from the list ⑥. 

 

 

① 

② 
③ 

⑤ ⑥
 

④ 
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Full Trace Log Files 

This file type contains the complete trace data for each log file entry. A maximum of 25 traces 
can be selected. 

 
 
Peak Level Log Files 

This file type contains two values for each log entry these being the level at the highest peak in 
the trace together with the corresponding frequency value. 
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Centre Level Log Files 

This type of file contains a single value for each log entry which is the value representing the 
level at the centre frequency of the original trace on the PSA. 

 

 

Screen Image Log Files  

This log file type contains a bitmap image of the trace for each log file entry. Moving the Highlight 
through the Log Entry list will show the bitmap image at each entry. 
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Scan Files (PSA Series 5 only) 

When a Scan file is opened a List window will be shown containing the scan data. The graphic 
window will also show the trace as it appeared on the PSA screen. 

Unlike a Trace file, which always contains 271 data points, a Scan file can contain any number of 
points between 541 and 210,000. A large scan file may take several seconds to load.  

 
Viewing Scan Files without Header Information (No State)  

The PSA Series 5 is capable of creating Scan files which contain no header information within the CSV 
file (see the PSA Series 5 Operating Manual). This capability is provided because some external 
programs can only import data which consists of frequency/amplitude pairs alone.  

When such a file is opened in Test Bridge PSA, information regarding RBW, VBW, Sweep Mode and 
Detector Type is not available, and that area of the graphics display window is left blank.  

Start, Stop, Centre and Span are calculated from the frequency values within the file, and the 
reference level is set in relation to the highest amplitude value found, to a resolution of 10dB.  
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Trace Files 

When a Trace file is opened a List window will be shown containing the trace data. The graphic 
window will also show the trace as it appeared on the PSA screen.  

The list window shows all 271 frequencies with their level values as they appear in the trace file from 
the PSA. The graphic window shows the data as it would appear on the PSA screen. This means that 
the level values in the two windows can differ depending upon the settings for fixed offsets and other 
parameters which are used to shift the trace.  

Image Files  

Opening an Image file will display a Windows bitmap image of the PSA screen. 
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 GRAPH CONTROLS 
Select an icon ① to enable the function.  

When a function is enabled, the icon will change state as shown ②. 

 

Pan 

Select the icon ② to move the graph along the X and Y axis. To zoom in and out freely, use the 
mouse wheel. 

Zoom 

To zoom in and out freely, use the mouse wheel. Alternatively select the rectangle zoom icon ③ and 
use the mouse to select an area to zoom into. 

Reset Zoom 

Select the icon ④ to reset to the default zoom level. Alternatively, right click and select Reset Zoom   

Export  

Any of the graph images can be exported as a SVG, PNG or PDF file. To export, select the Export icon 
⑤ followed by the required file type. A Windows file Save-As dialog will appear to allow the 
exported data to be written to a file.  

 
  

③
 

②
① ④

① ⑤
 

①
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 SAVING AND PRINTING  
Save a File  
To overwrite the existing file with any amendments made, select File > Save. 

To save the file as an entirely new one, select File > Save As.  

Export a File 
All files (with the exception of Image files and Screen Image Logs) can be exported to a .XML (*.xml) 
or .JSON (*.json) file. To export a file, select File >Export.  

A Windows file Save-As dialog will appear to allow the exported data to be written to a file. 

Export an Image 
Images can be exported directly from the graph, see ‘Export’ for more details. 

Print a Report  
A report contains the graph image alongside the log information and file details for the selected tab. 
To print a report, select File > Print.  

A print preview will appear, select Print to print the image. 
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 TRANSFERRING AND USING FILES 
Transferring and Using Limit Patterns  
Limit Pattern files created under PSA-Manager are stored in the TABLES folder (by default this will be 
Documents\PSAman\TABLES). Limit Patterns are identified by having the extension .CSV and 
having file names that do not begin with $.  

These must be transferred to the TABLES folder of the instrument (PSA\TABLES) using either a USB 
Flash drive or direct USB connection and “Link to PC”. 

(Setup/Functions > System/File Ops > File Ops > Link to PC)  

A Limit Pattern is loaded from the Level/Limits menu using:  

Level/Limits > Limits > Set Limits > (Limit 1/Limit 2) > Select Pattern.  

 

Transferring and Using Compensation Tables  
Compensation Table files created under PSA-Manager are stored in the TABLES folder (by default this 
will be My Documents\PSAman\TABLES). Compensation Tables are identified by having the 
extension .CMP  

These must be transferred to the TABLES folder of the instrument (PSA\TABLES) using either a USB 
Flash drive or direct USB connection and “Link to PC”. 

(Setup/Functions > System/File Ops > File Ops > Link to PC)  

A Compensation Table is loaded from the Level/Limits menu using:  

Level/Limits > Offset/Tables > Set > Comp. Table > Select Table.  

 

Transferring and Using Channel Markers  
Channel Marker files created under PSA-Manager are stored in the TABLES folder (by default this will 
be My Documents\PSAman\TABLES). Channel Markers are identified by having the extension .CSV 
and having file names that begin with $.  

These files must be transferred to the TABLES folder of the instrument (PSA\TABLES) using either a 
USB Flash drive or direct USB connection and “Link to PC” (Setup/Functions > System/File Ops > 
File Ops > Link to PC)  

A Channel Markers is loaded from the Level/Limits menu using Level/Limits > Limits > Set Limits > 
(Limit 1/Limit 2) > Select Pattern 

It is possible to display a combination of one channel markers file and one limit pattern or limit line. 
Note, however, that the Limits Comparator is disabled whenever is channel markers file is displayed. 
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 FILE UPGRADE  
Upgrading PSAxx02 setup Files to PSAxx03 Format 
Upgrade a file created a PSA2702 or PSA1302 so it can be read by a PSA2703 or PSA1303.  

To upgrade a file, select: Tools>File Upgrade>PSAxx02 to PSAxx03.  

Select the file(s) you would like to upgrade. 

Click Open. the files will be loaded, and a dialog box will appear stating the number of files that were 
successfully upgraded. 

NOTE 
The upgraded file(s) will be saved as original name.  

The original file(s) will be called <filename>.bak as a backup. 
 

 

 

 HELP OPTIONS 
Help - This PDF guide to using the software. 

About – Application details and a ‘report generator’ function to provide feedback. 

Quick Start – Quick access to instructions on how to use the software.  
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 TERMS AND CONDITIONS 
Freeware Licence Agreement of THURLBY THANDAR INSTRUMENTS LTD 
(TTI) 
Acknowledgement 

Carefully read the following terms and conditions before using this software. By using this freeware 
version you acknowledge that you have read this limited warranty, understand it, and agree to be 
bound by its terms and conditions. You also agree that unless you have a different Licence agreement 
signed by THURLBY THANDAR INSTRUMENTS LTD your use of this software indicates your acceptance 
of this Licence agreement and warranty. If you do not agree to the terms of this agreement, delete 
the software from all storage media.  

Licence 

This Freeware Licence Agreement (the "Agreement") is a legal agreement between you ("Licensee"), 
the end-user, and THURLBY THANDAR INSTRUMENTS LTD for the use of this software product 
("Software"). Commercial as well as non-commercial use is allowed. By using this Software or storing 
this program or parts of it on a computer hard drive (or other media), you agree to be bound by the 
terms of this Agreement.  

Provided that you verify that you are handling the original freeware version you are hereby licensed 
to make as many copies of the Freeware version of this Software and documentation as long as you 
do not charge money or request donations for such copies. You may not alter this Software in any 
way. You may not modify, rent or resell for profit this Software, or create derivative works based upon 
this Software.  

Governing Law 

This agreement shall be governed by the laws of England (UK). If any portion of this Agreement is 
deemed unenforceable by a court of competent jurisdiction, it shall not affect the forcibility of the 
other portions of this Agreement. Limited Warranty and Disclaimer of Warranty  

Limited Warranty and Disclaimer of Warranty 

THURLBY THANDAR INSTRUMENTS LTD EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE SOFTWARE. 
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE PROVIDED "AS IS" AND WITHOUT WARRANTIES 
AS TO PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR 
IMPLIED, OR NONINFRINGEMENT. THIS SOFTWARE IS NOT FAULT TOLERANT AND SHOULD NOT BE 
USED IN ANY ENVIRONMENT WHICH REQUIRES THIS. NO LIABILITY FOR DAMAGES. In no event 
THURLBY THANDAR INSTRUMENTS LTD or its suppliers be liable for any consequential, incidental or 
indirect damages whatsoever (including, without limitation, damages for loss of business profits, 
business interruption, loss of business information, or any other pecuniary loss) resulting of the use 
of or inability to use this SOFTWARE EVEN IF THURLBY THANDAR INSTRUMENTS LTD has been 
advised of the possibility of such damages. The entire risk resulting of use or performance of the 
software remains with you.  

Copyright  

Copyright (c) by THURLBY THANDAR INSTRUMENTS LTD. All rights reserved. 



EXCELLENCE THROUGH EXPERIENCE
Aim-TTi is the trading name of Thurlby 
Thandar Instruments Ltd. (TTi), one of 
Europe’s leading manufacturers of test 
and measurement instruments.

The company has wide experience in the 
design and manufacture of advanced 
test instruments and power supplies 
built up over more than thirty years.

The company is based in the United 
Kingdom, and all products are built at the 
main facility in Huntingdon, close to the 
famous university city of Cambridge.

TRACEABLE QUALITY SYSTEMS
TTi is an ISO9001 registered  company operating 
fully traceable quality systems for all processes 
from design through to final calibration.

ISO9001:2015

Certificate number FM 20695

WHERE TO BUY AIM-TTI PRODUCTS
Aim-TTi products are widely available from 
a network of distributors and agents in more 
than sixty countries across the world.

To find your local distributor, please visit our 
website which provides full contact details.

Designed and built in Europe by:

Thurlby Thandar Instruments Ltd.
Glebe Road, Huntingdon, Cambridgeshire.
PE29 7DR  United Kingdom
Tel: +44 (0)1480 412451  Fax: +44 (0)1480 450409 
Email: sales@aimtti.com   Web: www.aimtti.com

48511-1930           1
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